Advertisement

Old PowerPC Macs can run Firefox 17!

topic posted Sat, November 24, 2012 - 4:38 PM by  TimboNehead
Share/Save/Bookmark
I just installed this on my 10.5.8 iMac G5 and it is working great! Be sure to download the correct version for your particular G4, G5, or even G3 (Firefox 17 on an old Blueberry iMac is now possible!). Most of the latest add-ons, etc are supported but >plugins< (eg Flash, Silverlight, etc) are not supported. Yeah, read the instructions and download from here:

www.floodgap.com/software/tenfourfox/

This is free software that puts a spring in the step of your old Mac. In fact, I'm about to do some comparisons on page rendering on an G4 iBook…if it's like the G5 above, it'll be no contest and TenFourFox will be the default browser there until that iBook is retired.
Advertisement

Recent topics in "Mac OS X"